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Executive Summary

Redaction is the process of selectively removing visible and non-visible classified or sensitive information
from a document for release to a recipient (s) not cleared to view that information. The goal of the
process is to prevent inadvertent release of the information. The Portable Document Format (PDF) is a
common format for publishing documents on the web and for exchanging files between government
entities and government contractors. Redaction of PDF files is an ongoing challenge for these entities.
This document describes how to use Adobe Acrobat Professional X for redaction of PDF files.

What This Document Addresses

This document describes a procedure using Adobe Acrobat Professional X to redact information from
PDF documents. The original source of the document can be any application, but the process described
applies to documents that are already in PDF.

What This Document Does Not Address

This document does not address the purposeful or covert release of classified information, nor does it
address countermeasures for executable content vulnerabilities or any features of Adobe Acrobat
Professional X other than those related to redaction. The process described does not address starting
with documents in other formats or redaction using other tools.

Sources for Further Research
The NSA website, www.nsa.gov, contains related papers:

Redacting with Confidence: How to Safely Publish Sanitized Reports Converted From Word 2007
to PDF, 1333-TR-015R-2005.pdf

Hidden Data and Metadata in Adobe PDF Files, 1733-028R-2008.pdf

The Adobe website, www.adobe.com, contains many resources on the PDF format and Adobe products,
including forums for discussion of product questions.

Copyright 2019, The Sedona Conference
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1. Introduction

Redaction of information from documents is an ongoing challenge. There are multiple tools to assist the
user depending on the source file and the desired destination file type. NSA has released several papers
on the topic of redaction and the removal of hidden data in Microsoft Word and PDF files. These papers
are on the NSA.gov website. Adobe Acrobat Professional X (AAPX) includes improvements on the
redaction process and a new feature, Sanitize Document, to greatly enhance redaction capabilities. This
paper describes the use of AAPX in redaction.

2. New Features in Adobe Acrobat Professional X

Prior versions of Acrobat Pro had redaction functions spread across two menus, and the user had to
perform multiple steps to remove hidden data. Even after completing the steps, some complex
structures may have retained hidden data, such as layers in diagrams. In version X, Adobe added a
Sanitize Document function to accomplish a one-button sanitization that removes metadata, embedded
content and attached files, scripts, hidden layers, embedded search indexes, bookmarks, stored form
data, review and comment data, hidden data from previous document saves, obscured text and images,
comments hidden within the body of the PDF file, unreferenced data, links, actions and JavaScripts, and
overlapping objects.

The new Sanitize Document feature is different from the Remove Hidden Information feature which
allows the user to choose what content to remove and what to leave in. When the user selects Remove
Hidden Information, AAPX creates a list of items to remove and the user can un-select things to keep in
the document. The user must then click the Remove button to remove all of the selected items. On the
other hand, Sanitize Document removes everything in one step creating a “what you see is what you
get” document. In environments where the user must prepare many documents for declassification or
for release where no advanced functionality is necessary in the final copy, Sanitize Document will save
time and reduce the likelihood of process errors.

Complex images with hidden layers had to be handled individually in prior versions of Acrobat Pro.
Documents with diagrams, embedded spreadsheets, etc. had to be saved as JPEGs to insure removal of
hidden layers — the whole document had to be converted to JPEG images to ensure removal of all
hidden layers. AAPX now handles hidden layers correctly with both Sanitize Document and Remove
Hidden Information. The user is given the option to leave those items as is with the Remove Hidden
Information option.

3. Recommended Procedure for Redaction Using Adobe Acrobat X

Assuming the user is starting the redaction process with a PDF document (rather than a Microsoft Word
or other format), these are the high-level steps to perform redaction in AAPX (detailed steps are listed in
the next section):
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1. Start AAPX.

Turn off JavaScript. If you are trying to remove hidden malicious code from a document, it is

best to not be hit with it yourself.

Redact Information.
Apply Redactions.
Sanitize Document.

NG O B

4. Detailed Steps

4.1.  Turning Off JavaScript

(Optional) Save Document with File->SaveAs->Optimized PDF.

Open a copy of the original document in AAPX (always work with a copy).

For documents created by the user or from a known source, turning off JavaScript is optional. However,

this step is essential for sanitization of documents of unknown origin that might contain malware or

other executable content.

JavaScript is one of the things that should be removed from PDF documents during the redaction
process when the desire is to produce a “what you see is what you get” document. Since some PDF
documents might contain malicious JavaScript, it is best to not be hit with such attacks while trying to
prevent them. After opening AAPX and before opening a document, the user should turn off JavaScript:

1. On the top menu, select Edit->Preferences to bring up the Preferences dialog

2. Under Categories, select JavaScript. This brings up the JavaScript palate shown in Figure 1.

Preferences

)

Categories:

| Full Screen
| General

| Catalog

| Forms
Kentity

Intemet

| Reading

| Reviewing

| Search
Security

| Commenting
| Decuments

Page Display

|30 & Multimedia
| Accessibility
| Action Wizard

| Coler Management
| Convert From PDF
| Convert To PDF

| Intemational

lvascipt |
| Measuring {2D) 1
| Measuring 3D)

| Measuring (Geo)

| Multimedia (legacy)

| Multimedia Trust (legacy) |
| Onlline Services L

| Security (Enhanced)

JavaScript

4] [¥lEnable Acrobat JavaScript

JavaScript Security
[ Enable menu items JavaScript execution privileges

S [V Enable global object security policy

JavaScript Debugger

"] Enable JavaSeript debugger after Acrobat is restarted

Store breakpoints in PDF file

) lgnore Trace Break
[7] Enable interactive console
[} show console on emors and messages
JavaScript Editor

@ Use Acrobat JavaScript Editor

Font: | Courier New vl Sk 12

Use external JavaScript editor

! roweee

(oo ]

Figure 1: Preferences Dialog
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3. JavaScript is enabled by default as shown in Figure 1. Uncheck Enable Acrobat JavaScript and
leave everything else as shown above, then click OK.

Now it is safe to open the document for redaction.

4.2, Redacting Information and Apply Redactions

After opening a document in AAPX:

1. Open the Tools menu by clicking on Tools on the top right menu bar. This will open a menu that
should look like Figure 2 without the Protection menu expanded. Another way to get to this
menu is on the top menu bar, select View->Tools->Protection.

2. Expand the Protection menu option which will look like the Figure 2.

Tools | Comment | Share
Er

» Pages

» Content

» Forms
v+ Action Wizard

r Recognize Text

v Protection
@ Encrypt ~
More Protection - |

Black Out & Remove Content

@ Mark for Redaction

@ Mark Pages to Redact

‘ﬁ Apply Redactions

&) Redaction Properties

% Search & Remove Text
Hidden Information

B Remove Hidden Information

G Sanitize Document

» Sign & Certify

+ Print Production

» Analyze

Figure 2: Protection Menu

3. Select Mark For Redaction. This will display the dialog shown in Figure 3 stating that redaction
requires two steps: Mark for Redaction and Apply Redactions. Click OK.
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Using Redaction Tools

Redaction allows you to permanently black out and remove sensitive content.
Redaction requires two steps:

E‘ 1. Mark for Redaction

.’f; 2, Apply Redactions

Mote:
Redactions are not applied permanently until you select Apply Redactions.

1

| [ Don't show again

S

Figure 3: Redaction Dialog

4. The cursor is now a redaction cursor. Place the cursor at the beginning of the area you want to
redact. Click the left mouse button, hold it down, and drag the cursor over the information to
redact. This will create a red outline around the information you are redacting as shown in
Figure 4. When you mouse over an outlined area, it will turn black to indicate how the area will
look in the final copy.

The newer XML metadats stream is
shown in Figure 3. The XMP schemas define how
the metadata will be stored, including what
fields are available.

Following the XMP entry, a document
information dictionary entry may also exist with
ruch of the same data that was in the XML, For e

Figure 4: Redaction Outline Marks

5. After you have marked all of the areas for redaction, select Apply Redactions on the right panel
menu. This will display a dialog stating “You are about to permanently remove all content that
has been marked for redaction. Once the document is saved, this operation cannot be undone.
Are you sure you want to continue?” Select OK.

After Apply Redactions, the red outlines are filled with black as shown in Figure 5.

stream is
shown in Figure 3. Tha XMP schemas define how
the metadata will be stored, including what
fields are available.

Following the XMP entry, a document

infarmation dictinnare antry maw alen ayict with

Figure 5: Redaction Black Box Marks
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43.

After applying redactions, you will see a dialog box that says “Redactions have been successfully
applied. Would you like to also find and remove hidden information in your document?” Select
no. You can choose this option from the right panel later, or later chose Sanitize Document
instead.

You can continue to Mark and Apply in the document. When you are finished marking all of the
redactions, you are ready to sanitize the document.

Sanitize Document

After marking and applying all of the redactions for the document:

44,

1. Select Sanitize Document from the right panel menu. This brings up a dialog shown in Figure 6.

Sanitize Document

i Sanitize Docurnent removes hidden data and metadata from your document so
QW that sensitive information is not inadvertently passed along when you publish
your PDF, Sanitize Document will remove:

* Metadata

* Embedded content and attached files
* Scripts

. * Hidden layers

i * Embedded search indexes

i * Stored form data i
§ * Review and comment data

i * Hidden data from previous document saves

* Obscured text and images

* Cornments hidden within the body of the PDF file
* Unreferenced data

* Links, actions and javascripts

* Overlapping objects

i Press QK to begin the sanitization process by selecting a location to save your
sanitized document.

|1 Do not show this message again

[ o [ cancel

Figure 6: Sanitize Document Dialog

Select OK, you will be prompted to save a copy of the document. AAPX tries to minimize the risk
of overwriting the original after you have removed all of the functionality of forms and scripts.
Save the document. The changes are not final until you save the document. If you started with a

copy, just save to whatever file you are working with. If you started with the original, be sure to
save to a different filename.

Changing Redaction Properties

The user can customize the redaction properties rather than using the default black box mark. The right
panel menu includes a Redaction Properties choice which displays the dialog in Figure 7a.
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Redaction Tool Properties *‘"ﬁ ! Redaction Teol Properties *"" A
e TN g = NG pmnera
Appearance | General || | Aepearance |Generat)
Redacted Area Fill Color: {7 Use Overlay Text | Redacted Area Fill Color: [Il] [V] Use Qverlay Text ‘
Overlay Text Overlay Text i
Fan Helvetica Font Size: {10 ] Fant: [Heive’tica v| Font Size: ‘10 i
Aute-Size text to fit redaction region Repeat Overlay Text | | [ | Auto-Size text to fit redaction region [ | Repeat Overlay Text |
] V Text Alignment: %1 E—%] Font Calor: @
) Custom Text | @ Custorn Text: [MY oVERLAY TEXT | 1
Redaction Code: 1 '. ") Redaction Code: !tb'l (1) (&) | It
i B
- E LS, FOLA - |
El | | LLS, Privacy Act 1E] |
i
i
i Edit Code fle o E
I
Redaction Mark Appearance i Redaction Mark Appearance
QOutline Color: [E Filt Color: [S‘J Outline Color: E':! Fill Colern I\S—B
\ Filt Opacity: ] jfno% 1 Fill Opacity: I} 100%
g . S ! .
| Locked | oK I I Cdpael { I i Locked [ oK ] [ Cancel }

Figure 7a: Default Redaction Properties Figure 7b: Modified Redaction
Dialog Properties Dialog

The figure on the left shows the default settings. Some redaction may require redaction marks that
explain the reason for the redaction, such as for U.S. FOIA or U.S. Privacy Act requirements. AAPX allows
the user to insert custom text in the redaction marks. To insert custom text, check Use Overlay Text on
the top right of the dialog. The greyed-out fields become usable and the user can insert either custom
text or choose Redaction Code from the codes shown in the dialog. Be careful not to use classified or
sensitive text as the custom overlay text.

Figure 8 shows how the redaction marks appear with the Custom Text set to MY OVERLAY TEXT as
shown in figure 7b above:

MY OV ] stream is
shown in Figure 3. The XMP schemas define how |
the metadata will be stored, including what
fields are available.

Figure 8: Redaction Mark with Custom Text

The user can change the outline, font and fill colors using the Redaction Properties dialog.
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4.5, Choosing Remove Hidden Information instead of Sanitize Document

Sanitize Document removes all form and JavaScript functionality from the document, all tags, all
comments, everything! In those cases where the user needs to leave some functionality in the
document, the user can use the Remove Hidden Information option and select individual items to leave
in the document; however, this reduces the assurance that all hidden data is removed and means the
user must save the document as optimized PDF (see next section). Sanitize Document includes
optimizing the PDF format. The Remove Hidden Information option should only be used for special
circumstances. Sanitize Document is the recommended option otherwise.

When the user selects Remove Hidden Information, AAPX searches the document for hidden
information and displays a checklist on the left menu pane as shown in Figure 9:

[ . risks_old p - Adobe Acrobat Pra
File Edit View Window Help

;‘I‘E}Create' t@@m'@@'@
SIS 2 v"Zﬁl Ik & "— () | a7% v—H |

'EJ Remove Hidden Information €]

=

=)~

Status:
ﬁ‘ Finding Hidden Information...Done

Results:

BT pdf_risks_old.pdf
£ 9 Metadata (1 item)
E @ Document (1 item)
|8 Show preview
El & Bookmarks (1 item)
55 Show preview
« Deleted or cropped content (1 tem]
7 Links, actions and javascripts (1 item)
4 Overlapping ohjects (4 pages)

S e

Figure 9: Remove Hidden Information Check List

The user can preview each piece of hidden information identified by AAPX and de-select items to leave
in the document. When finished reviewing the checklist, the user has to hit the Remove button which
brings up a warning dialog requiring the user to hit OK.

4.6.  (Optional) File->SaveAs->Optimized PDF

Multiple vendors have applications that create PDF files. These files are not always well-formed or
standardized PDF and could contain sensitive or classified remnant data within the file format. The
Sanitize Document option includes optimizing the PDF format to correct these problems. However, if the
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user chose Remove Hidden Data instead of Sanitize Document (see previous section), the user should

then save the file as Optimized PDF.

1. Select File->SaveAs->Optimized PDF from the top menu. This brings up the dialog in Figure 10.

W Images

™ Fonts

U Transparency
¥ Discard Objects
VI Discard User Data
¥l Clean Up

Current PDF Version: 1.6 (Acrobat 7.x)

Image Settings

ColorImages:

D ple: [Bicubic D ?

Compression: | JPEG vj Quality: | Medium -}

Grayscale Images

D ple: [Bicubic Downsomplingto_+| fi50  ppifor images above [225  ppi.
Compression: | JPEG -] Quality: [Medium |

Monochrome Images :

D ‘E;\Jbl(r' to vJ 300  ppiforimages above [450  ppi

[V] Optimize images only if there is a reduction in size

All units are in pixels per inch (ppi).

Cox J [ onet ]

Figure 10: PDF Optimizer Dialog

2. Uncheck Fonts to retain embedded fonts. If the embedded fonts are removed and not available

on the recipient’s system, the system will substitute fonts which could affect the appearance of
the document and the alignment of the redaction marks. Some situations may require removal
of embedded fonts, but in general redaction tasks this is optional.

3. If you have already run Remove Hidden Data or plan to run it, you do not need to change any
other options. Hit OK. You will be prompted for a filename, enter a filename and hit OK again.

5.

Conclusion

When using AAPX for redaction of sensitive or classified information from documents meant for public
release, the steps outlined in this paper with the Sanitize Document option are the recommended
procedure. This produces a “what you see is what you get” final document.
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